安装Mongod
(不推荐这种方法啊….用yum装吧….)
下载并解压
1 | curl -0 地址 |
安装service启动工具
官网方法
1 | yum install -y mongodb-org-server-3.2.3 |
发现使用service mongod start 无法启动
踩坑…然后重装报错:
1 | ** WARNING: You are running this process as the root user, which is not recommended. |
解决办法:
用yum装mongod 然后将数据文件目录设置允许权限给mongod
1 | chown -R mongod:mongod /data |
再次执行 即可使用service工具
注意
mongod不能用kill -9 终止,用kill -2 ,都则会导致无法启动。
解决办法:删除/data/db 下lock文件.